Bugs in version 2.1.x I noticed

    Share
    avatar
    Zeomak
    Elite Sinner
    Elite Sinner

    Posts : 155
    Points : 196
    Reputation : 0
    Join date : 2010-06-01
    Age : 31
    Location : Gemany

    Bugs in version 2.1.x I noticed

    Post by Zeomak on 2011-02-10, 5:02 am

    Ok it's not much, but if I find anything else I will update the thread.

    1. 3 mobs attack the char. 1 skill is set to be used once HP go below 70%. This skill is in CD. Another one is set to be used on 50 %. The charackter just stands there until either the 1st skill is out of cooldown or the HP go down 2 50% so the 2nd skill is used.

    2. Right after the situation above the charackter kills all 3. But if a 4th monster joins the fight this monster is "ignored" after the 1st three are dead and the char runs to the next closed mob.

    3. Even so "Pick up in Battle" is unchekced the char picks up (not always but sometimes) items of mobs it killed even so it is still being attacked by another mob.

    4.Radius and range are set so the charackter doesnt leave the area. But once the charackter reaches a position close to the starting position OR at the edge of the raidius set it starts flying. Not to the starting position but to the edge of the radius. It then just hovers there looking in front then changing direction. It doesnt land, and fly mode cannot be deactivated manually anymore. The Flymount has 2 be unequipped and SINS has 2 be stopped.

    Edit: Seems that it doesn't happen when I deactivate "Auto Revive"

    Edit2: Still flies around, but this time to starting position. When it attemts a landing it activates and deactivates the flymode rapidly. And the strange thing is: I now unchecked the radius!

    5.Had my Stun skill (Head Hunt lvl 10) set when in PK mode. (Maybe a mistake on my part?) I tested it with a friend of mine. The result was that my char had enough sparks 2 use the skill but went and killed its opponent with normal attacks. But the next mob it attacked was stunned with Head Hunt.

    And the final thing is not rlly a bug but a suggestion:

    Saving coordinates (like the Save Location in SINS 2.x but still different) and setting a radius from that location. Making the bot return there if either there is no mob in his radius anymore or it is close/crossing the set radius.


    But I don't want to spoil everything. U did a great job. Were there are bugs there is praise aswell. I'm verry glad 2 see that Sparks can now be used w/o the char loosing and completly ignoring it's target.


    Update 1:
    I set the Trigger Shutdown Computer > Self HP = 0

    I then went out, when I came back the PC was off so I assumed the char had died. But when I logged on it was almost the same coords I left it and with almost full HP.


    Update 2:

    Ok that is MORE then strange, and annoying one.... I wanted 2 st up one of my Bot chars (BM) to grind at foxwing supremes. The result was that I configured it as I used to:

    Self HP% less then 50 = Diamond Sutra

    If Status Effect does not Contain "Skill ID 65" (only entered 65 though)

    Normal Attack if Current target HP are greater then 0

    The result is this: The bot starts, buffs himself. (I activate the bot when its flying cause, as we all know, Foxies are airborn)Then it either targets nothing, or the wrong one (mostly some lvl 4 ground mob) or IF it targets a Foxwing then it hits it once. Yes only once. Then it deactivates Flymode, ractivates it a few meters lower, and flies into the middle of the area. There it hovers only changing its face direction.

    I have Auto Triger, Auto Revive Deactivated. So... With Auto Trigger Deactivated, why does it even deactivate Flymode? Oh and when something dropped on the only occausion in like 20 tries that it did kill the mob it attacked and something got droped, it didnt pick it. It the just flew to the middle again and hovered. (FOr over an hour)

    Ergo Only option I have is to bot with my main at groundmobs with good droprate. The problem with that is what I wrote further above. It just flies to a specific spot all the time why the heck? W/O this it wouldnt be so obvious but it's verry frequent. So it kills like 2-3 mobs and then flies back again. Srry but I can't run any further tests since it just doesn't work out with my botting chars. (The only unable 2 fly char (lvl 28 sin) with which I tryed got booted. Had the "Unable to Fly" Message and boot right after.)


    When I start Flymode and the char "starts" to fly on a mob 2 make its one hit, the action when I activate Flymode is labeld "Action 20" and When it starts approching the Mob it says "Action Multi" once it disengages it says "Action Idle"


    Update:
    The things above are still the ones I noticed. Just repeated tests with 2.1.1.4

      Current date/time is 2017-04-26, 10:22 pm