status ID does not register/missing

    Share

    xjiyo
    Elite Sinner
    Elite Sinner

    Posts : 55
    Points : 88
    Reputation : 0
    Join date : 2010-09-25
    Age : 29
    Location : Philippines

    status ID does not register/missing

    Post by xjiyo on 2011-02-14, 1:32 pm

    screenshot explaining what skill is to be use.......


    screenshot with sins activated with admin tab and data viewer included showing information while buff is not activated......


    screenshot after buff use, showing packet sent and not registering data @ data viewer tab.....


    this is needed for triggering buff only when self or party does not contains status....

    vuduy
    Site Admin
    SINSBOT Creator


    Site AdminSINSBOT Creator

    Posts : 888
    Points : 1266
    Reputation : 176
    Join date : 2010-03-17
    Age : 40
    Location : Canada

    Re: status ID does not register/missing

    Post by vuduy on 2011-02-14, 1:39 pm

    Status Id has nothing to do with packets; do you even know what the Admin tab is for?

    What does SINS recognize your game client as? Whatever your version is, the offset for status effect is not the same as PWI.

    Status Id are learned whenever the Status line in your Information tab registers.

    xjiyo
    Elite Sinner
    Elite Sinner

    Posts : 55
    Points : 88
    Reputation : 0
    Join date : 2010-09-25
    Age : 29
    Location : Philippines

    Re: status ID does not register/missing

    Post by xjiyo on 2011-02-14, 2:03 pm

    im sorry sir, i just thought if i include the packets in my inquiry it might help...sins recognizes my version a PW-VN..but i didn't quite understand this
    vuduy wrote:Status Id are learned whenever the Status line in your Information tab registers.
    ...i would be glad if you could enlighten me a bit...

    xjiyo
    Elite Sinner
    Elite Sinner

    Posts : 55
    Points : 88
    Reputation : 0
    Join date : 2010-09-25
    Age : 29
    Location : Philippines

    Re: status ID does not register/missing

    Post by xjiyo on 2011-02-14, 2:35 pm

    do you mean it should look like this?


    vuduy
    Site Admin
    SINSBOT Creator


    Site AdminSINSBOT Creator

    Posts : 888
    Points : 1266
    Reputation : 176
    Join date : 2010-03-17
    Age : 40
    Location : Canada

    Re: status ID does not register/missing

    Post by vuduy on 2011-02-14, 4:04 pm

    No. I'll update the offset for PW-VN later. It should work with next version.

    xjiyo
    Elite Sinner
    Elite Sinner

    Posts : 55
    Points : 88
    Reputation : 0
    Join date : 2010-09-25
    Age : 29
    Location : Philippines

    Re: status ID does not register/missing

    Post by xjiyo on 2011-02-14, 4:13 pm

    ok thank you very much....

    vuduy
    Site Admin
    SINSBOT Creator


    Site AdminSINSBOT Creator

    Posts : 888
    Points : 1266
    Reputation : 176
    Join date : 2010-03-17
    Age : 40
    Location : Canada

    Re: status ID does not register/missing

    Post by vuduy on 2011-02-14, 4:16 pm

    Actually, I can't find the offset because I don't have the PW-PH client.

    The PW-VN client has been updated.

    If you know how to use CheatEngine, then I'll show you how to find the Status Effect offset.

    Your version is probably missing Pet-List offset too; your Pet tab does not show any pets (playing Werefox) does it?

    xjiyo
    Elite Sinner
    Elite Sinner

    Posts : 55
    Points : 88
    Reputation : 0
    Join date : 2010-09-25
    Age : 29
    Location : Philippines

    Re: status ID does not register/missing

    Post by xjiyo on 2011-02-14, 4:49 pm

    yes..even in the old sins it doesn't show any pets...i have some knowledge of cheat engine...i've used it to hack some facebook games...i guess i can follow your instructions just show me how...

    vuduy
    Site Admin
    SINSBOT Creator


    Site AdminSINSBOT Creator

    Posts : 888
    Points : 1266
    Reputation : 176
    Join date : 2010-03-17
    Age : 40
    Location : Canada

    Re: status ID does not register/missing

    Post by vuduy on 2011-02-14, 4:57 pm

    1. Attach CE to your game
    2. Use a character that can turn on/off a buff (example Werefox turning into fox form and back)
    3. Activate buff (example turn into fox form), make sure you have only one buff icon
    4. In CE, search for value 1 (Exact Value 4 bytes)
    5. Deactivate buff (example turn back into human form, you have no buff icons)
    6. In CE, search next for value 0
    Repeat 3-6 until you have only 1 address left
    7. Add that address to CE list
    8. Right click address and select "Find out what access this address"
    9. Activate buff
    10. An entry should popup in CE Debug window, double click on it
    11. Show me the output of CE debug window.

    xjiyo
    Elite Sinner
    Elite Sinner

    Posts : 55
    Points : 88
    Reputation : 0
    Join date : 2010-09-25
    Age : 29
    Location : Philippines

    Re: status ID does not register/missing

    Post by xjiyo on 2011-02-14, 5:51 pm

    A) there two addresses thats left..i tried repeating step 3-6 about 20times but still there are two...



    1) finding out what access address 0D7DAAE8 first....



    1.1) double clicking entries from the debug window consecutively...









    2) finding out what accesses address 0D7DAD24...



    2.1) double clicking entries from debug window consecutively...





    vuduy
    Site Admin
    SINSBOT Creator


    Site AdminSINSBOT Creator

    Posts : 888
    Points : 1266
    Reputation : 176
    Join date : 2010-03-17
    Age : 40
    Location : Canada

    Re: status ID does not register/missing

    Post by vuduy on 2011-02-14, 6:56 pm

    Restart your SINS, status effect should be displaying properly now.

    Check the Information tab -> Status

    xjiyo
    Elite Sinner
    Elite Sinner

    Posts : 55
    Points : 88
    Reputation : 0
    Join date : 2010-09-25
    Age : 29
    Location : Philippines

    Re: status ID does not register/missing

    Post by xjiyo on 2011-02-15, 3:17 am

    nice..it works now..thank you!....

    Sponsored content

    Re: status ID does not register/missing

    Post by Sponsored content Today at 12:14 pm


      Current date/time is 2017-01-24, 12:14 pm