[2.1.1.9] Problems with buffing and weird status bar message

    Share
    avatar
    fouryearstrong
    Elite Sinner
    Elite Sinner

    Posts : 221
    Points : 293
    Reputation : 3
    Join date : 2010-08-03
    Location : Philippines

    [2.1.1.9] Problems with buffing and weird status bar message

    Post by fouryearstrong on 2011-02-15, 12:06 pm

    ok i know the Any surrounding players is under testing phase but i just had to report this.

    this is related to my buffers (Vim and Skysong). Recently after updating to 2.1.1.9 my SINS' status bar looks like this everytime i start the bot with my buffers:



    triggers i've used for Cherub's Song:

    Any surrounding player: distance from self is less than or equal to [10]
    Any surrounding player: is a summoned clone (false)
    Any surrounding player: is in the same guild (true)
    Any surrounding player: status effect does not contain [9] << Slam
    Any surrounding player: status effect does not contain [23] << Increased Health
    Self: MP current is greater than or equal to [215]

    what happens is that it checks the players around the buffer but it doesn't buff them even though the conditions are met.

    same type of triggers are used for my Skysong's Bodhi's Protector and it too gets that weird status bar message and doesn't buff anyone.
    avatar
    vuduy
    Site Admin
    SINSBOT Creator


    Site AdminSINSBOT Creator

    Posts : 888
    Points : 1266
    Reputation : 176
    Join date : 2010-03-17
    Age : 40
    Location : Canada

    Re: [2.1.1.9] Problems with buffing and weird status bar message

    Post by vuduy on 2011-02-15, 12:12 pm

    The error above is interesting.

    As for your trigger, it will only execute if the player doesn't have BOTH slam + increased health. If it has one of those buffs, then it will not execute.

    However, that error alone will stop the execution of the trigger and hence won't execute.

    Does this error happen EVERYTIME or only sometimes? If you disable all other skills, and run the bot, will the error always popup or only certain conditions?

    PS: your name still shows up in the error. Remember to block it next time.
    avatar
    fouryearstrong
    Elite Sinner
    Elite Sinner

    Posts : 221
    Points : 293
    Reputation : 3
    Join date : 2010-08-03
    Location : Philippines

    Re: [2.1.1.9] Problems with buffing and weird status bar message

    Post by fouryearstrong on 2011-02-15, 12:27 pm

    oohh.. i thought there was no name in the error >.< lemme replace the image xD

    i only have 1 skill setup for each of my buffers. the buff skill only. yes it happens all the time. although a few hours ago i managed to make it work by removing then adding the skill again. but it gave me a hard time. i've added/removed the skill several times before making it work. oh by the way, i was in town then when i managed to make it work. in this screenshot i'm in shura.
    avatar
    Kagebunshin
    Global Moderator
    Global Moderator

    Posts : 195
    Points : 271
    Reputation : 6
    Join date : 2010-03-19
    Age : 37
    Location : Outta Space

    Re: [2.1.1.9] Problems with buffing and weird status bar message

    Post by Kagebunshin on 2011-02-15, 12:34 pm

    Ok I checked SINS a bit yesterday.
    Normal attack works good, I can use my esper skill and another attack skill too. But everytime I use a self-buff (clan skills, expertise skills, etc) or I set an AOE, all skills were only casted 1 time. After that, my char only uses the normal attack.

    avatar
    vuduy
    Site Admin
    SINSBOT Creator


    Site AdminSINSBOT Creator

    Posts : 888
    Points : 1266
    Reputation : 176
    Join date : 2010-03-17
    Age : 40
    Location : Canada

    Re: [2.1.1.9] Problems with buffing and weird status bar message

    Post by vuduy on 2011-02-15, 4:52 pm

    vuduy wrote:The error above is interesting.

    As for your trigger, it will only execute if the player doesn't have BOTH slam + increased health. If it has one of those buffs, then it will not execute.

    However, that error alone will stop the execution of the trigger and hence won't execute.

    Does this error happen EVERYTIME or only sometimes? If you disable all other skills, and run the bot, will the error always popup or only certain conditions?

    PS: your name still shows up in the error. Remember to block it next time.

    In this case, one of the condition is causing the error. Start with the top, adding 1 by 1; and test. Find out which condition causes that error and let me know.
    avatar
    fouryearstrong
    Elite Sinner
    Elite Sinner

    Posts : 221
    Points : 293
    Reputation : 3
    Join date : 2010-08-03
    Location : Philippines

    Re: [2.1.1.9] Problems with buffing and weird status bar message

    Post by fouryearstrong on 2011-02-15, 9:25 pm

    ok i've tested those triggers one by one and here's what i've found out:

    each trigger works perfectly. but when i tried the Any surrounding player: status effect does not contain trigger, that error message appeared. though it still worked.


    i tried to put all the triggers again to test it again. it works fine if there's only one person in your range. if there's like more than 2 people in your range then it constantly checks each character and doesn't buff.


    EDIT:
    by the way the reason i've added Increased Health in the conditions is because arden's array and vim's cherub's song have the same status ID. though they appear as separate buffs in-game. but when i put my buffer in town i only use the status ID for Slam.

    Sponsored content

    Re: [2.1.1.9] Problems with buffing and weird status bar message

    Post by Sponsored content


      Current date/time is 2017-04-28, 7:14 am